Technical Information Center

WC601A Wire and Tubing Cutter

Problem Possible Cause Possible Solution
Blade stuck in the closed position Blade hitting the cut bushing Re-Install cut bushing (See the cut bushing installation procedure)
Material doesn’t feed properly Belt feed not adjusted correctly Tighten the belt feed adjusting knob clockwise to increase tension (Do not over tighten, this will cause material to jam)
Cut bushing too small Re-Install cut bushing (See the cut bushing installation procedure)
Display not functioning Blown fuse Replace with recommended fuse
Unit not powered up Turn power switch on, in the rear of the unit
Incorrect voltage supplied Make certain the incoming voltage is correct and is NOT being influenced by large equipment upstream.
Poor quality of cut or no cut Dull or chipped blades Dull or chipped blades must be replaced
Cut bushings not installed correctly Re-Install Cut bushings (See the Cut bushing installation procedure)
Erratic cut lengths Uneven Dereeler tension Make sure at high speeds, a power assisted dereeler is used
Feed belts not adjusted correctly Tighten the feed belt adjusting knob clockwise to increase tension clockwise to increase tension
Cut bushing too small Re-Install cut
ALSO SEE OPERATING MANUAL FOR DIAGRAMS
Resources
WC601A Product Page
Download Operating Manual
Technical Documentation: WC601A Wire and Tubing Cutter

Can’t find your answer above?

* Required Fields
Technical Assistance

© Copyright 2022 ∙ The Eraser Company, IncFAQ'sPrivacy Statement